AVI from security camera won't play

The Perian forums have moved to Google Groups, this forum is read only.

AVI from security camera won't play

Postby wef » Thu Apr 14, 2011 12:23 am

I'm not very familiar with different encoding methods, but I've usually been able to work my way through issues - but this time no luck.

I have a H.264 security camera system with a DVR that creates a "backup" A/V file from the recorded history. This file has a .avi extension, and plays back fine using Windows Media Player. I use Parallels to run Windows 7 in order to control this system, but I want to be able to play the A/V backup files with Mac OSX on other scanning stations.

So far I have not been able to get these files to play under OSx. Standard QT 10.0 in Snow Leopard just says it can't be played and refers me to a web site for plugins. Divx and Flip4Mac don't solve the problem. With Perian installed it no longer refuses to launch QT but it goes into an endless wait saying "Loading Movie....". The QTKitServer process takes over the full CPU bandwidth and never gets the file open.

I have tested this with a fairly small file (10 seconds of video, about 500MB) so I think an hour of waiting for the file to load should be sufficient to show that it never will complete. After a few minutes the app becomes unresponsive and requires a Force Quit. Before then I can quit normally.

Any help from you experts would be greatly appreciated.

Don
wef
Harmless
 
Posts: 3
Joined: Wed Apr 13, 2011 11:53 pm

Re: AVI from security camera won't play

Postby gbooker » Thu Apr 14, 2011 8:33 am

We need a sample of the file to proceed further.
gbooker
Cocoaforge Admin
 
Posts: 723
Joined: Fri May 05, 2006 9:47 pm

Re: AVI from security camera won't play

Postby wef » Thu Apr 14, 2011 9:23 am

Here is a 10-second recording. First try to attach was refused because of the .avi extension. Will try with .zip.
Attachments
20110413110000_CH03_759812.avi.zip
(396.41 KiB) Downloaded 493 times
wef
Harmless
 
Posts: 3
Joined: Wed Apr 13, 2011 11:53 pm

Re: AVI from security camera won't play

Postby gbooker » Thu Apr 14, 2011 7:21 pm

I really tire of these people that can't be bothered to create valid avi files. One of the many reasons I want AVI to die a quick and painful death.

That aside, the codec used is IMM5, which from what I can tell, is proprietary and is not in any library we can use. This means we cannot use this codec. At least the code can be changed so it doesn't hit an infinite loop.
gbooker
Cocoaforge Admin
 
Posts: 723
Joined: Fri May 05, 2006 9:47 pm

Re: AVI from security camera won't play

Postby The_Tick » Thu Apr 14, 2011 7:40 pm

Does it play in vlc?
User avatar
The_Tick
Cocoaforge Admin
 
Posts: 4642
Joined: Thu Dec 02, 2004 1:06 am

Re: AVI from security camera won't play

Postby wef » Fri Apr 15, 2011 12:32 am

VLC says "No suitable decoder module. VLC does not support the audio or video format "IMM5". Unfortunately there is no way for you to fix this".

Thanks for checking - at least I can quit obsessing about how I should be able to get it working.

In case this thread may help others, this DVR is part of an inexpensive 4-camera system made by Samsung and sold by Costco. The model number is SDE-120. In addition to controls on a directly connected monitor, it has a nice web-enabled control interface that only works completely with an Active-X control that runs under Internet Explorer. The live web stream can be viewed on Mac OSx with Firefox or Safari, or Safari on iOS, but without the ActiveX control it shows only one camera at a time and users cannot view or control playback of recorded images.

To be fair, the specifications for this device do say that it will work only with IE on Windows, and the fact that it does provide limited viewing on other browsers is not claimed. I also cannot find any specification of requirements for playing the saved "backup" file.

Don
wef
Harmless
 
Posts: 3
Joined: Wed Apr 13, 2011 11:53 pm


Return to Perian

Who is online

Users browsing this forum: No registered users